Red Hat 9 での GD::Graph

2004-4-24 12:03
このエントリーをはてなブックマークに追加

japan.linux.com の記事『GD::Graphを使ったPerlグラフ生成』を読んで、GD::Graph を試してみようと思ったのですが、Red Hat Linux 9 には、perl の GD モジュールが含まれていません。そこでインストールを試みたのですが次のようなエラーが発生しました。

  {standard input}: Assembler messages:
  {standard input}:573: Error: symbol `__u' is already defined
  {standard input}:579: Error: symbol `__u' is already defined
  {standard input}:585: Error: symbol `__u' is already defined

これは、gd-devel パッケージがインストールされていないためでした。そこで気を取り直して gd-devel パッケージをインストールして再実行したものの、エラーが無くなりません。いろいろ調べてから分かったのですが、perl の GD モジュールは、GD の 2.0.1 以降でないと動かないようです。Red Hat Linux 9 の gd はバージョンが 1.8.4 と古いためか、make に失敗してしまいます。というわけで断念しました。fedora を使えということですね。

  • ブックマーク : アクセス: 3,682回
  • カテゴリー : Linux
  • キーワード : , ,

コメントはまだありません

No comments yet.

Sorry, the comment form is closed at this time.

67 queries. HTML convert time: 1.230 sec. Powered by WordPress. Valid XHTML
Copyright © 2003-2017 @ futuremix.org ログイン