Xpdf と poppler

2007-10-17 12:34
このエントリーをはてなブックマークに追加

pdftotext コマンドを使用しようと思ったら、CentOS 5 では xpdf パッケージがなくなっていました。いろいろ調べてみると、xpdf から folk した poppler というライブラリに差し変わっていたようです。

しかし、poppler の RPM パッケージは入っているのですが pdftotext などのコマンドが使えません。これはライブラリのみが poppler に、コマンド類は poppler-utils というパッケージにまとまっているのでこちらもインストールする必要がありました。

  # yum install poppler-utils.x86_64

xpdf 3.0 からの分岐のですが、バージョンは popller 0.5.4 となっています。PDF1.6 にも対応していましたし、コピー制限のかかっている PDF でも pdftotext でテキスト化できてしまいました。これってどうなんでしょうかね。

pdftohtml では Copying of text from this document is not allowed. というエラーがでて弾かれるのですが。

  • ブックマーク : アクセス: 15,607回
  • カテゴリー : Linux
  • キーワード :

コメントはまだありません

No comments yet.

Sorry, the comment form is closed at this time.

67 queries. HTML convert time: 1.270 sec. Powered by WordPress. Valid XHTML
Copyright © 2003-2017 @ futuremix.org ログイン