WordPress ME 2.1.3 で RSS フィードが配信されない

2007-4-9 23:35
このエントリーをはてなブックマークに追加

WordPress 2.1.3 と 2.0.10 がリリースされました。セキュリティ関連の修正がありますので、利用している人はバージョンアップをしましょう。

ただ、気をつけなければならないのは WordPress ME の 2.1.3 を新規インストールする場合です。不具合があり RSS・ATOM フィードが配信されなくなってしまいます。2.1.2 からの差分については現在のところ問題ないようです。

フルパッケージ版の修正方法は「WordPress Japan :: トピックを表示 – 2.1.3 にしたら RSS, ATOM が配信されない」に書かれているとおり、wp-includes/author-template.php の 14行目付近に抜けている関数を追加します。

  function wpj_the_author($deprecated = '', $deprecated_echo = true) {
   if ( $deprecated_echo )
      echo wpj_utf8_encode(get_the_author());
   return wpj_utf8_encode(get_the_author());
}

追記

4月10日以前にダウンロードした人対象に WordPress ME2.1.3 修正パッチがリリースされています。上記の修正が入っているそうです。

コメントはまだありません

No comments yet.

Sorry, the comment form is closed at this time.

72 queries. HTML convert time: 1.668 sec. Powered by WordPress. Valid XHTML
Copyright © 2003-2017 @ futuremix.org ログイン